Risikostufe 3

Titel:Squid: Mehrere SchwachstellenDatum:08.05.2020Software:Open Source Squid <= 4.7, Open Source Squid <= 5, SUSE Linux, Red Hat Enterprise Linux, Oracle LinuxPlattform:UNIX, Linux, WindowsAuswirkung:Ausführen beliebigen Programmcodes mit den Rechten des DienstesRemoteangriff:JaRisiko:mittelCVE Liste:CVE-2019-12519, CVE-2019-12520Bezug: Oracle Linux Security Advisory ELSA-2020-2040 vom 2020-05-08

Beschreibung

Squid ist ein Open-Source Web Proxy Cache für Unix und Windows Plattformen. Die Software unterstützt Proxying und Caching von HTTP, FTP und anderen Protokollen, sowie SSL und Access Control Lists.

Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Squid ausnutzen, um beliebigen Programmcode mit den Rechten des Dienstes auszuführen oder Sicherheitsvorkehrungen zu umgehen.