Risikostufe 3

Titel:libssh: Schwachstelle ermöglicht CodeausführungDatum:16.12.2019Software:Open Source libssh < 0.8.8, Open Source libssh < 0.9.3, Ubuntu Linux, Red Hat Fedora, SUSE LinuxPlattform:LinuxAuswirkung:Ausführen beliebigen ProgrammcodesRemoteangriff:JaRisiko:mittelCVE Liste:CVE-2019-14889Bezug: SUSE Security Update SUSE-SU-2019:3293-1 vom 2019-12-14

Beschreibung

libssh ist eine C Bibliothek für das Anbieten von SSH Diensten auf Client- und Serverseite. Sie kann genutzt werden, um aus der Ferne Programme auszuführen, Dateien zu übertragen oder als sicherer und transparenter Tunnel für entfernte Programme genutzt werden.

Ein entfernter, authentisierter Angreifer kann eine Schwachstelle in libssh ausnutzen, um beliebigen Programmcode auszuführen.