Risikostufe 3

Titel:Squid: Mehrere SchwachstellenDatum:05.12.2019Software:Open Source Arch Linux, Open Source Squid < 4.9, SUSE Linux, Ubuntu LinuxPlattform:Linux, UNIX, WindowsAuswirkung:Ausführen beliebigen ProgrammcodesRemoteangriff:JaRisiko:mittelCVE Liste:CVE-2019-12526, CVE-2019-18678, CVE-2019-18679Bezug: Ubuntu Security Notice USN-4213-1 vom 2019-12-04

Beschreibung

Squid ist ein Open-Source Web Proxy Cache für Unix und Windows Plattformen. Die Software unterstützt Proxying und Caching von HTTP, FTP und anderen Protokollen, sowie SSL und Access Control Lists.

Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Squid ausnutzen, um beliebigen Programmcode auszuführen, um Informationen offenzulegen und um Anfragen zu manipulieren.